aboutsummaryrefslogtreecommitdiffstats
path: root/main/gamin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gamin/APKBUILD')
-rw-r--r--main/gamin/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/main/gamin/APKBUILD b/main/gamin/APKBUILD
index bf5b3bca28..3e0647d8e5 100644
--- a/main/gamin/APKBUILD
+++ b/main/gamin/APKBUILD
@@ -1,14 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gamin
pkgver=0.1.10
-pkgrel=5
+pkgrel=6
pkgdesc="Gamin is a file and directory monitoring system defined to be a subset of the FAM (File Alteration Monitor) system."
url="http://www.gnome.org/~veillard/gamin"
arch="all"
license="GPL"
-subpackages="$pkgname-dev"
+subpackages="$pkgname-dev py-$pkgname:py"
depends=
-makedepends="pkgconfig glib-dev"
+makedepends="pkgconfig glib-dev python-dev"
source="http://www.gnome.org/~veillard/$pkgname/sources/$pkgname-$pkgver.tar.gz"
build ()
@@ -31,4 +31,10 @@ package() {
make DESTDIR="$pkgdir" install
}
+py() {
+ pkgdesc="Python bindings for the gamin library"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
md5sums="b4ec549e57da470c04edd5ec2876a028 gamin-0.1.10.tar.gz"