aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index e69d23163d..3ccfd40477 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -123,6 +123,11 @@ build() {
_languages="$_languages,java"
fi
+ # --enable-target-optspace is broken on powerpc
+ if [ "$CARCH" != "powerpc" ]; then
+ _target_optspace="--enable-target-optspace"
+ fi
+
msg "Building the following:"
echo ""
echo " CBUILD=$CBUILD"
@@ -130,6 +135,7 @@ build() {
echo " CTARGET=$CTARGET"
echo " languages=$_languages"
echo " dynamic_linker=$_dynamic_linker"
+ echo " target_optspace=$_target_optspace"
echo ""
mkdir -p "$_builddir"
@@ -154,7 +160,7 @@ build() {
--enable-esp \
--enable-languages=$_languages \
--enable-shared \
- --enable-target-optspace \
+ $_target_optspace \
--enable-tls \
--enable-threads \
$_dynamic_linker \