aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gcr/APKBUILD')
-rw-r--r--main/gcr/APKBUILD52
1 files changed, 15 insertions, 37 deletions
diff --git a/main/gcr/APKBUILD b/main/gcr/APKBUILD
index 1c6de14883..4c30449a2a 100644
--- a/main/gcr/APKBUILD
+++ b/main/gcr/APKBUILD
@@ -2,61 +2,38 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gcr
-pkgver=3.34.0
+pkgver=3.36.0
pkgrel=0
pkgdesc="A library for bits of crypto UI and parsing"
url="https://wiki.gnome.org/Projects/CryptoGlue"
arch="all"
license="LGPL-2.0-or-later"
makedepends="glib-dev gtk+3.0-dev libgcrypt-dev p11-kit-dev
- gobject-introspection-dev libxslt vala"
-checkdepends="python3"
+ gobject-introspection-dev libxslt vala meson gtk-doc"
+checkdepends="xvfb-run dbus-x11"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-base"
source="https://download.gnome.org/sources/gcr/${pkgver%.*}/gcr-$pkgver.tar.xz
- remove-failing-test.patch"
+ allow-building-without-gpg.patch
+ dont-run-gpg-tests.patch"
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
--localstatedir=/var \
- --enable-introspection \
- --enable-vala
- make
+ --buildtype=plain \
+ -Dgpg_path=/usr/bin/gpg2 \
+ output
+ ninja -C output
}
check() {
- # only run tests that does not require gnupg to avoid circular dependency:
- # gcr -> gnupg -> pinentry -> gcr
- make check TESTS="
- test-asn1 test-asn1x test-dn
- test-decimal test-hex test-hkdf
- test-oid test-secmem test-padding
- test-symkey test-armor test-openssl
- test-dh
- test-gck-attributes test-gck-module
- test-gck-slot test-gck-session
- test-gck-object test-gck-crypto
- test-gck-uri test-gck-enumerator
- test-gck-modules
- test-secret-exchange test-simple-certificate
- test-certificate test-certificate-chain
- test-subject-public-key test-fingerprint
- test-pkcs11-certificate test-openpgp
- test-openssh test-secure-memory
- test-trust test-parser
- test-memory-icon test-gnupg-key
- test-gnupg-process
- test-ssh-askpass
- "
+ xvfb-run ninja -C output test
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
base() {
@@ -68,5 +45,6 @@ base() {
"$subpkgdir"/usr/lib
}
-sha512sums="9314b531ed46a42b2c8c1531c7d95003db04f2c8065e46f4e6a84ec26400ce6302ea71c4db42a8c7b98884a0b84d75a0ca65d988aa0fe6de6d897d772b070093 gcr-3.34.0.tar.xz
-1e2d8641a3ccc9989704c901ea636c2a6e3c8cd0bc86193bf9c178f7edbddda7158846cb07099ef4098c774a0bcb7a45ddbbd093ce7b5355cca2f7ac3a2d6130 remove-failing-test.patch"
+sha512sums="0431e7971b73accc62869c9497fcff7c111c453aa6a8ff25b42f19ceae1be0aec52e0e4eb504676f967c6e4f179198c15c521278690822e3457dbc5fe512fd5e gcr-3.36.0.tar.xz
+7cca3fd0512621129f0a0c532a3592b4ea0e49f887cf5935b1a104363d08fca05dbba470672561efa4b8b02efdbe22c948f989af26fdb32833a82383393207f0 allow-building-without-gpg.patch
+e4fc2248497e7103980e9baf9444505649ee93c657c7a82c042ae62d7c54b2764ad7bc9780467ceda5e53a23fa11dc4957898929c7d7f995d9d0d205d18d5eb7 dont-run-gpg-tests.patch"