aboutsummaryrefslogtreecommitdiffstats
path: root/main/gettext/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gettext/APKBUILD')
-rw-r--r--main/gettext/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/main/gettext/APKBUILD b/main/gettext/APKBUILD
index d1ae2925e1..e0fb5df5f2 100644
--- a/main/gettext/APKBUILD
+++ b/main/gettext/APKBUILD
@@ -32,9 +32,6 @@ prepare() {
build() {
cd "$_builddir"
- # http://bugs.gentoo.org/show_bug.cgi?id=81628
- export CPPFLAGS="$CPPFLAGS -I/usr/include/libxml2"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -56,10 +53,16 @@ package() {
libintl() {
replaces="gettext"
mkdir -p "$subpkgdir"/usr/lib
+
+ rm -rf "$pkgdir"/usr/lib/charset.alias
+ rmdir -p "$pkgdir"/usr/lib 2>/dev/null
+
if [ "$ALPINE_LIBC" != "eglibc" ]; then
mv "$pkgdir"/usr/lib/libintl.so.* \
"$subpkgdir"/usr/lib || return 1
fi
+
+ return 0
}
md5sums="3fc808f7d25487fc72b5759df7419e02 gettext-0.18.3.1.tar.gz"