aboutsummaryrefslogtreecommitdiffstats
path: root/main/git/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/git/APKBUILD')
-rw-r--r--main/git/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index 96e1aae8dd..df9250b6ef 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -23,7 +23,7 @@
# - CVE-2017-1000117
pkgname=git
pkgver=2.24.2
-pkgrel=0
+pkgrel=1
pkgdesc="Distributed version control system"
url="https://www.git-scm.com/"
arch="all"
@@ -31,7 +31,6 @@ license="GPL-2.0-or-later"
# we need tcl and tk to be built before git due to git-gui and gitk
makedepends="zlib-dev openssl-dev curl-dev expat-dev perl-dev python3-dev
pcre2-dev asciidoc xmlto perl-error tcl tk"
-options="!check" # Check is currently failing on t3900-i18n-commit.sh ISO-2022-JP.txt
# note that order matters
subpackages="$pkgname-doc
$pkgname-bash-completion:completion:noarch
@@ -69,6 +68,7 @@ prepare() {
USE_LIBPCRE2=YesPlease
NO_SYS_POLL_H=1
CFLAGS=$CFLAGS
+ ICONV_OMITS_BOM=Yes
EOF
# The multimail hook is installed with git. Use python3 to avoid an
@@ -84,6 +84,13 @@ build() {
make prefix=/usr DESTDIR="$pkgdir" perllibdir=$(_perl_config vendorlib)
}
+check() {
+ make prefix=/usr DESTDIR="$pkgdir" \
+ perlibdir=$(_perl_config vendorlib) \
+ GIT_SKIP_TESTS='t3900 t4061 t4124 t5003 t5616 t5703 t7063 t9020' \
+ test
+}
+
package() {
cd "$builddir"