aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtest
diff options
context:
space:
mode:
Diffstat (limited to 'main/gtest')
-rw-r--r--main/gtest/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/gtest/APKBUILD b/main/gtest/APKBUILD
index 63c701bc0a..6596d39d8d 100644
--- a/main/gtest/APKBUILD
+++ b/main/gtest/APKBUILD
@@ -1,14 +1,15 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gtest
pkgver=1.8.1
-pkgrel=0
+pkgrel=1
pkgdesc="Google Test - C++ testing utility based on the xUnit framework (like JUnit)"
url="https://github.com/google/googletest"
arch="all"
options="!check" # googletest-death-test-test hangs
license="BSD-3-Clause"
depends=""
-makedepends="python2-dev cmake"
+depends_dev="${pkgname}=${pkgver}-r${pkgrel} gmock=${pkgver}-r${pkgrel} cmake"
+makedepends="$depends_dev python2-dev"
install=""
subpackages="$pkgname-dev gmock"
source="$pkgname-$pkgver.tar.gz::https://github.com/google/googletest/archive/release-$pkgver.tar.gz