aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtk+3.0
diff options
context:
space:
mode:
Diffstat (limited to 'main/gtk+3.0')
-rw-r--r--main/gtk+3.0/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/main/gtk+3.0/APKBUILD b/main/gtk+3.0/APKBUILD
index c2e178a21c..a19514289d 100644
--- a/main/gtk+3.0/APKBUILD
+++ b/main/gtk+3.0/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gtk+3.0
-pkgver=3.4.2
+pkgver=3.4.3
pkgrel=0
pkgdesc="The GTK+ Toolkit (v3)"
url="http://www.gtk.org/"
@@ -57,6 +57,11 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
|| return 1
+ # the configure script checks if isnan is a function. In uclibc
+ # isnan is there, but as a macro
+ # https://bugzilla.gnome.org/show_bug.cgi?id=676087
+ echo "#define HAVE_ISNAN 1" >> config.h
+ echo "#define HAVE_ISINF 1" >> config.h
make || return 1
}
@@ -69,4 +74,4 @@ package() {
find "$pkgdir" -name *.la -delete
}
-md5sums="9e20443fbaa3ba3e9cbd2fc44d6be121 gtk+-3.4.2.tar.xz"
+md5sums="e552d52c3b0824eb99842dc9c5f4875f gtk+-3.4.3.tar.xz"