aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtk-doc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gtk-doc/APKBUILD')
-rw-r--r--main/gtk-doc/APKBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/main/gtk-doc/APKBUILD b/main/gtk-doc/APKBUILD
index 0055c0e6f8..5e7a826500 100644
--- a/main/gtk-doc/APKBUILD
+++ b/main/gtk-doc/APKBUILD
@@ -1,34 +1,41 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gtk-doc
pkgver=1.26
-pkgrel=0
+pkgrel=1
pkgdesc="Documentation tool for public library API"
url="http://www.gtk.org/gtk-doc/"
arch="noarch"
license="GPL FDL"
-depends="docbook-xsl gnome-doc-utils perl pkgconfig python2"
+depends="docbook-xsl gnome-doc-utils perl python2 py2-six pkgconf glib-dev highlight"
makedepends="rarian-dev py-libxml2 gettext itstool"
-source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- cd "$_builddir"
-}
+checkdepends="bc"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz
+ 0001-tests-Label-parts-with-decimals-not-roman-numerals.patch
+ "
+# it does not seem to be possible to disable tests of pdf which requires dblatex or fop
+# disable checks for now
+options="!check"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- || return 1
- make || return 1
+ --with-highlight=highlight
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-sha512sums="91f0e0e51d9f77794c0ab57bad5c2da242252f029ab2d4252f8740ccf8b18fed49a7f010f654f5ba60ebed74f7b65a5ef1f762c8661eebfcacfe15dc3bc3c52c gtk-doc-1.26.tar.xz"
+sha512sums="91f0e0e51d9f77794c0ab57bad5c2da242252f029ab2d4252f8740ccf8b18fed49a7f010f654f5ba60ebed74f7b65a5ef1f762c8661eebfcacfe15dc3bc3c52c gtk-doc-1.26.tar.xz
+a86438a9cbbf1bb60d2aea93f10a473f3fe7814cdbf0a454ff42bea88e79f21f9e748e063335aa6332878fa8f8a1c00ef288a44631b510471cc6bb806851b391 0001-tests-Label-parts-with-decimals-not-roman-numerals.patch"