aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtk-doc
diff options
context:
space:
mode:
Diffstat (limited to 'main/gtk-doc')
-rw-r--r--main/gtk-doc/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/gtk-doc/APKBUILD b/main/gtk-doc/APKBUILD
new file mode 100644
index 0000000000..cd434296bb
--- /dev/null
+++ b/main/gtk-doc/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gtk-doc
+pkgver=1.17
+pkgrel=0
+pkgdesc="Documentation tool for public library API"
+url="http://www.gtk.org/gtk-doc/"
+arch="all"
+license="GPL FDL"
+depends="docbook-xsl gnome-doc-utils perl pkgconfig"
+makedepends="rarian-dev py-libxml2 gettext"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="ca52ca10845089da6966d810709d4ee3 gtk-doc-1.17.tar.bz2"