aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtk-vnc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gtk-vnc/APKBUILD')
-rw-r--r--main/gtk-vnc/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/main/gtk-vnc/APKBUILD b/main/gtk-vnc/APKBUILD
new file mode 100644
index 0000000000..4be0e9cca6
--- /dev/null
+++ b/main/gtk-vnc/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gtk-vnc
+pkgver=0.4.3
+pkgrel=2
+pkgdesc="A VNC viewer widget for GTK"
+url="http://live.gnome.org/gtk-vnc"
+arch="all"
+license="LGPL"
+subpackages="$pkgname-dev gvncviewer"
+makedepends="gnutls-dev gtk+-dev libiconv-dev gettext-dev intltool expat-dev
+ libgcrypt-dev libgpg-error-dev cyrus-sasl-dev perl-text-csv"
+depends_dev="gtk+-dev gnutls-dev"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --without-python \
+ --with-examples \
+ --disable-static || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la
+}
+
+gvncviewer() {
+ pkgdesc="Demo application for gtk-vnc"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+md5sums="38d3fbacb5d00e630f939e88858206f1 gtk-vnc-0.4.3.tar.bz2"