aboutsummaryrefslogtreecommitdiffstats
path: root/main/iceauth
diff options
context:
space:
mode:
Diffstat (limited to 'main/iceauth')
-rw-r--r--main/iceauth/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/iceauth/APKBUILD b/main/iceauth/APKBUILD
index 77fad92b3b..d75a8e9dae 100644
--- a/main/iceauth/APKBUILD
+++ b/main/iceauth/APKBUILD
@@ -10,8 +10,15 @@ subpackages="$pkgname-doc"
depends=
makedepends="pkgconfig libice-dev"
source="http://xorg.freedesktop.org/releases/individual/app/iceauth-$pkgver.tar.bz2"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -22,7 +29,7 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
md5sums="975ade3f238c1eb10705da0a91e6e8e7 iceauth-1.0.3.tar.bz2"