aboutsummaryrefslogtreecommitdiffstats
path: root/main/iftop
diff options
context:
space:
mode:
Diffstat (limited to 'main/iftop')
-rw-r--r--main/iftop/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/main/iftop/APKBUILD b/main/iftop/APKBUILD
index 26a8b0fd86..4d5aca4300 100644
--- a/main/iftop/APKBUILD
+++ b/main/iftop/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iftop
pkgver=0.17
-pkgrel=2
+pkgrel=3
pkgdesc="iftop does for network usage what top(1) does for CPU usage"
url="http://www.ex-parrot.com/~pdw/iftop/"
arch="all"
@@ -11,8 +11,14 @@ makedepends="libpcap-dev>=1 ncurses-dev"
subpackages="$pkgname-doc"
source="http://www.ex-parrot.com/~pdw/$pkgname/download/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/iftop-$pkgver
+prepare() {
+ cd "$_builddir"
+ update_config_sub
+}
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -23,7 +29,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
}
md5sums="062bc8fb3856580319857326e0b8752d iftop-0.17.tar.gz"