aboutsummaryrefslogtreecommitdiffstats
path: root/main/inputproto/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/inputproto/APKBUILD')
-rw-r--r--main/inputproto/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/main/inputproto/APKBUILD b/main/inputproto/APKBUILD
new file mode 100644
index 0000000000..2cd469843e
--- /dev/null
+++ b/main/inputproto/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=inputproto
+pkgver=2.0.2
+pkgrel=0
+pkgdesc="X11 Input extension wire protocol"
+url="http://xorg.freedesktop.org/"
+arch="noarch"
+license="custom"
+source="http://xorg.freedesktop.org/releases/individual/proto/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+ install -m755 -d "$pkgdir"/usr/share/licenses/$pkgname
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+md5sums="07d54ae098ed4e6dce472f6ef3de05ce inputproto-2.0.2.tar.bz2"