aboutsummaryrefslogtreecommitdiffstats
path: root/main/iproute2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/iproute2/APKBUILD')
-rw-r--r--main/iproute2/APKBUILD25
1 files changed, 8 insertions, 17 deletions
diff --git a/main/iproute2/APKBUILD b/main/iproute2/APKBUILD
index 9109405646..686a0cf438 100644
--- a/main/iproute2/APKBUILD
+++ b/main/iproute2/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iproute2
-pkgver=4.9.0
+pkgver=4.10.0
_realver=$pkgver
pkgrel=0
pkgdesc="IP Routing Utilities"
@@ -13,16 +13,11 @@ makedepends="bison flex bash iptables-dev libelf-dev"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="http://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
musl-fixes.patch"
+builddir="$srcdir"/$pkgname-$_realver
-_builddir="$srcdir"/$pkgname-$_realver
prepare() {
- cd "$_builddir"
- local i
- for i in $source; do
- case $i in
- *.patch) msg "$i"; patch -p0 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare || return 1
+ cd "$builddir"
sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
sed -i 's:/usr/local:/usr:' tc/m_ipt.c include/iptables.h || return 1
@@ -31,7 +26,7 @@ prepare() {
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -44,7 +39,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
}
@@ -60,9 +55,5 @@ bashcomp() {
rmdir -p "$pkgdir"/usr/share 2>/dev/null || true
}
-md5sums="44a8371a4b2c40e48e4c9f98cbd41391 iproute2-4.9.0.tar.xz
-ea8ff3227b0b90717e305e0cdd7c158f musl-fixes.patch"
-sha256sums="c0f30f043f7767cc1b2cd2197b08d4e9b2392c95823fabe30bbce308c30116c4 iproute2-4.9.0.tar.xz
-57678dafb510bf1797240d0713d173c9aa2f7bf137471fe490d07daaf68dd5f7 musl-fixes.patch"
-sha512sums="0d974d7c001eac75def0d90b628e432d9847024843d02a6cd27266ff30e3f7a9c874fa91115da74db5f321c2e815b486a847059ca6df3aa8ea49432ffa39a889 iproute2-4.9.0.tar.xz
-bb8f1f76e0f0a33785ee884b05ad8242780f2069dd9362624ec03b9952d567cac612febd9928b59fd489d5032fb97f179de13676c044cc533cf5280de932ce86 musl-fixes.patch"
+sha512sums="e54477e167455e7ef5da4adc168d63eaa96091b63dc987fffe918cbb005eceed18a62283ca99ee2512dc0e960f47ae21b39ffbe399c1612fd9cea147c34c581b iproute2-4.10.0.tar.xz
+93dd53e15a78cb9e408b1ca20f89a53838bfef8caa22615c2b504d28a429f93fa69e0762927481552275d544a26b1dba148e73151fd67d5971ebd2d3f57ed6c7 musl-fixes.patch"