aboutsummaryrefslogtreecommitdiffstats
path: root/main/iptables
diff options
context:
space:
mode:
Diffstat (limited to 'main/iptables')
-rw-r--r--main/iptables/APKBUILD2
-rw-r--r--main/iptables/iptables.initd6
2 files changed, 4 insertions, 4 deletions
diff --git a/main/iptables/APKBUILD b/main/iptables/APKBUILD
index 52278757ac..8384b6dba1 100644
--- a/main/iptables/APKBUILD
+++ b/main/iptables/APKBUILD
@@ -2,7 +2,7 @@
pkgname=iptables
pkgver=1.4.12.2
-pkgrel=2
+pkgrel=3
pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
url="http://www.iptables.org/"
arch="all"
diff --git a/main/iptables/iptables.initd b/main/iptables/iptables.initd
index 3de25229d4..fa10476ce1 100644
--- a/main/iptables/iptables.initd
+++ b/main/iptables/iptables.initd
@@ -64,7 +64,7 @@ start() {
ebegin "Loading ${iptables_name} state and starting firewall"
${iptables_bin}-restore ${SAVE_RESTORE_OPTIONS} < "${iptables_save}"
eend $?
- if [ "${IPFORWARD}" = yes ]; then
+ if yesno "${IPFORWARD}"; then
ebegin "Enabling forwarding"
/sbin/sysctl -w ${sysctl_ipfwd}=1 > /dev/null
eend $?
@@ -72,12 +72,12 @@ start() {
}
stop() {
- if [ "${IPFORWARD}" = yes ]; then
+ if yesno "${IPFORWARD}"; then
ebegin "Disabling forwarding"
/sbin/sysctl -w ${sysctl_ipfwd}=0 > /dev/null
eend $?
fi
- if [ "${SAVE_ON_STOP}" = "yes" ] ; then
+ if yesno "${SAVE_ON_STOP}"; then
save || return 1
fi
checkkernel || return 1