aboutsummaryrefslogtreecommitdiffstats
path: root/main/lame/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lame/APKBUILD')
-rw-r--r--main/lame/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/lame/APKBUILD b/main/lame/APKBUILD
index 0b4d4e5b45..3708772097 100644
--- a/main/lame/APKBUILD
+++ b/main/lame/APKBUILD
@@ -10,12 +10,18 @@ license="LGPL2+"
subpackages="$pkgname-dev $pkgname-doc"
depends=
makedepends="nasm ncurses-dev autoconf automake libtool"
-source="http://downloads.sourceforge.net/project/lame/lame/$_ver/lame-$pkgver.tar.gz"
+source="http://downloads.sourceforge.net/project/lame/lame/$_ver/lame-$pkgver.tar.gz
+ lame-automake-1.12.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
# link fronted shared
sed -i -e 's/\(^LDFLAGS.*\)-static/\1/g' frontend/Makefile.am
@@ -53,4 +59,5 @@ package() {
fi
}
-md5sums="84835b313d4a8b68f5349816d33e07ce lame-3.99.5.tar.gz"
+md5sums="84835b313d4a8b68f5349816d33e07ce lame-3.99.5.tar.gz
+54814745b84480da3b643582f2e5b485 lame-automake-1.12.patch"