aboutsummaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32/0001-libm-x86_64-implement-fesetround.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/libc0.9.32/0001-libm-x86_64-implement-fesetround.patch')
-rw-r--r--main/libc0.9.32/0001-libm-x86_64-implement-fesetround.patch98
1 files changed, 0 insertions, 98 deletions
diff --git a/main/libc0.9.32/0001-libm-x86_64-implement-fesetround.patch b/main/libc0.9.32/0001-libm-x86_64-implement-fesetround.patch
deleted file mode 100644
index 84d6a2e08b..0000000000
--- a/main/libc0.9.32/0001-libm-x86_64-implement-fesetround.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From b58032ae6a34afc1887d9a6f3d05891d0d4fdbab Mon Sep 17 00:00:00 2001
-From: Natanael Copa <natanael.copa@gmail.com>
-Date: Sun, 28 Nov 2010 12:43:33 +0000
-Subject: [PATCH] libm/x86_64: implement fesetround
-
-from glibc
----
- libm/x86_64/Makefile.arch | 24 +++++++++++++++++++++++
- libm/x86_64/fesetround.c | 46 +++++++++++++++++++++++++++++++++++++++++++++
- 2 files changed, 70 insertions(+), 0 deletions(-)
- create mode 100644 libm/x86_64/Makefile.arch
- create mode 100644 libm/x86_64/fesetround.c
-
-diff --git a/libm/x86_64/Makefile.arch b/libm/x86_64/Makefile.arch
-new file mode 100644
-index 0000000..e1be961
---- /dev/null
-+++ b/libm/x86_64/Makefile.arch
-@@ -0,0 +1,24 @@
-+# Makefile for uClibc
-+#
-+# Copyright (C) 2000-2008 Erik Andersen <andersen@uclibc.org>
-+#
-+# Licensed under the LGPL v2.1, see the file COPYING.LIB in this tarball.
-+#
-+# The routines included in this math library are derived from
-+# glibc's libm.
-+#
-+
-+ifeq ($(UCLIBC_HAS_FENV),y)
-+libm_ARCH_SRC:=$(wildcard $(libm_ARCH_DIR)/*.c)
-+libm_ARCH_OBJ:=$(patsubst $(libm_ARCH_DIR)/%.c,$(libm_ARCH_OUT)/%.o,$(libm_ARCH_SRC))
-+endif
-+
-+libm_ARCH_OBJS:=$(libm_ARCH_OBJ)
-+
-+ifeq ($(DOPIC),y)
-+libm-a-y+=$(libm_ARCH_OBJS:.o=.os)
-+else
-+libm-a-y+=$(libm_ARCH_OBJS)
-+endif
-+libm-so-y+=$(libm_ARCH_OBJS:.o=.os)
-+
-diff --git a/libm/x86_64/fesetround.c b/libm/x86_64/fesetround.c
-new file mode 100644
-index 0000000..3d2ef4c
---- /dev/null
-+++ b/libm/x86_64/fesetround.c
-@@ -0,0 +1,46 @@
-+/* Set current rounding direction.
-+ Copyright (C) 2001, 2005 Free Software Foundation, Inc.
-+ This file is part of the GNU C Library.
-+
-+ The GNU C Library is free software; you can redistribute it and/or
-+ modify it under the terms of the GNU Lesser General Public
-+ License as published by the Free Software Foundation; either
-+ version 2.1 of the License, or (at your option) any later version.
-+
-+ The GNU C Library is distributed in the hope that it will be useful,
-+ but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ Lesser General Public License for more details.
-+
-+ You should have received a copy of the GNU Lesser General Public
-+ License along with the GNU C Library; if not, write to the Free
-+ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-+ 02111-1307 USA. */
-+
-+#include <fenv.h>
-+
-+int
-+fesetround (int round)
-+{
-+ unsigned short int cw;
-+ int mxcsr;
-+
-+ if ((round & ~0xc00) != 0)
-+ /* ROUND is no valid rounding mode. */
-+ return 1;
-+
-+ /* First set the x87 FPU. */
-+ __asm__ ("fnstcw %0" : "=m" (*&cw));
-+ cw &= ~0xc00;
-+ cw |= round;
-+ __asm__ ("fldcw %0" : : "m" (*&cw));
-+
-+ /* And now the MSCSR register for SSE, the precision is at different bit
-+ positions in the different units, we need to shift it 3 bits. */
-+ __asm__ ("stmxcsr %0" : "=m" (*&mxcsr));
-+ mxcsr &= ~ 0x6000;
-+ mxcsr |= round << 3;
-+ __asm__ ("ldmxcsr %0" : : "m" (*&mxcsr));
-+
-+ return 0;
-+}
---
-1.7.3.2
-