aboutsummaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libc0.9.32/APKBUILD')
-rw-r--r--main/libc0.9.32/APKBUILD48
1 files changed, 29 insertions, 19 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 11843bdfc1..83d89a5b7f 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -1,33 +1,41 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
_abiver=0.9.32
pkgname=libc$_abiver
-_gitver=1008060645
+_gitver=1009151331
pkgver=${_abiver}_alpha0_git$_gitver
-pkgrel=4
+pkgrel=0
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
-
+options=
subpackages="uclibc-dev:dev uclibc-utils:utils"
depends_dev="linux-headers=>2.6.32"
-#options="!strip"
replaces=uclibc
+DEBUG=y
+if [ -n "$DEBUG" ]; then
+ options="!strip"
+fi
+
+
_snapurl="http://git.uclibc.org/uClibc/snapshot/master.tar.bz2"
_snapfile="$pkgname-$pkgver.tar.bz2"
source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
compat-stack-guard.patch
uclibc-libm-pic.patch
- uclibc-resolv-tls.patch
- 0001-config-parser-fix-memory-corruption.patch
- 0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch
- 0001-netdb-increase-line-size-for-etc-services.patch
0001-create-DEVEL_PREFIX-MULTILIB_DIR-dir-rather-than-DEV.patch
- getproto.patch
- ld-tls.patch
+
+ 0001-config-parser-do-not-assume-that-realloc-return-same.patch
+ 0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch
+ 0003-config-parser-always-initialize-line-pointer.patch
+
uclibcconfig.x86
uclibcconfig.i486
"
+# uclibc-resolv-tls.patch
+# 0001-config-parser-fix-memory-corruption.patch
+# 0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch
+# ld-tls.patch
_config="$srcdir"/uclibcconfig.${ARCH:-x86}
_builddir="$srcdir"/master
@@ -73,6 +81,11 @@ build() {
_kh=KERNEL_HEADERS="$SYSROOT/include"
fi
cp "$_config" .config
+ if [ -n "$DEBUG" ]; then
+ sed -i -e 's/# DODEBUG is not set/DODEBUG=y' \
+ -e 's/DOSTRIP=y/# DOSTRIP is not set/' \
+ .config
+ fi
make silentoldconfig
make -j1 pregen KERNEL_HEADERS="$SYSROOT"/usr/include \
CROSS="$CROSS" || return 1
@@ -104,15 +117,12 @@ utils() {
mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin/
}
-md5sums="2b3935c370307b806320e78883f9b07c libc0.9.32-0.9.32_alpha0_git1008060645.tar.bz2
+md5sums="966c830f294a8ab5069cc03a61e1b2ed libc0.9.32-0.9.32_alpha0_git1009151331.tar.bz2
4d408f72142ce55a0754948cc9cfe447 compat-stack-guard.patch
2f9739a980be24a842c57516155c7885 uclibc-libm-pic.patch
-d08831b452acdeaa3037525ee617edab uclibc-resolv-tls.patch
-d351ca4e5c33f4a7a60d4f1d754db5c4 0001-config-parser-fix-memory-corruption.patch
-653b046611f98c990f1b52a28968ece3 0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch
-39ac96d750ad058030f917912bfea466 0001-netdb-increase-line-size-for-etc-services.patch
9dd8192227f54d6d3ccb49dc54137ff3 0001-create-DEVEL_PREFIX-MULTILIB_DIR-dir-rather-than-DEV.patch
-18afaad25c578bfbe1c7ddb0bea1228a getproto.patch
-b769ffe8e6df01328fc6afb4b50da1cd ld-tls.patch
-e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.x86
-e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.i486"
+ba6e0370d1fc19e5903696de412507ef 0001-config-parser-do-not-assume-that-realloc-return-same.patch
+19d923997f9625ce6f16d8128bbcba65 0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch
+99b817778f4ef3a1b194740ea08990b4 0003-config-parser-always-initialize-line-pointer.patch
+2ca97ab4b49f920247f335184bb02c1c uclibcconfig.x86
+2ca97ab4b49f920247f335184bb02c1c uclibcconfig.i486"