aboutsummaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32/ld-tls.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/libc0.9.32/ld-tls.patch')
-rw-r--r--main/libc0.9.32/ld-tls.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/main/libc0.9.32/ld-tls.patch b/main/libc0.9.32/ld-tls.patch
new file mode 100644
index 0000000000..057191c57e
--- /dev/null
+++ b/main/libc0.9.32/ld-tls.patch
@@ -0,0 +1,16 @@
+diff --git a/libpthread/nptl/Makefile.in b/libpthread/nptl/Makefile.in
+index 99a726a..3e9676a 100644
+--- a/libpthread/nptl/Makefile.in
++++ b/libpthread/nptl/Makefile.in
+@@ -48,9 +48,9 @@ libc-shared-routines-y := $(addprefix $(libpthread_OUT)/,$(libc-shared-routines-
+ libc-static-routines-y := $(addprefix $(libpthread_OUT)/,$(libc-static-routines-y:.c=.o))
+ libc-shared-y += $(libc-shared-routines-y) $(libpthread_libc_OBJS:.o=.oS)
+ ifeq ($(DOPIC),y)
+-libc-static-y += $(libc-static-routines-y:.o=.os) $(libpthread_libc_a_OBJS:.o=.os) # $(libpthread_ld_tls_COBJ:.o=.os)
++libc-static-y += $(libc-static-routines-y:.o=.os) $(libpthread_libc_a_OBJS:.o=.os) $(libpthread_ld_tls_COBJ:.o=.os)
+ else
+-libc-static-y += $(libc-static-routines-y) $(libpthread_libc_a_OBJS) # $(libpthread_ld_tls_COBJ)
++libc-static-y += $(libc-static-routines-y) $(libpthread_libc_a_OBJS) $(libpthread_ld_tls_COBJ)
+ endif
+
+ librt-pt-routines-y := $(patsubst %.c,$(libpthread_pthread_OUT)/%.o,$(filter-out $(notdir $(libpthread_librt_OBJS:.o=.c)), $(librt-pt-routines-y)))