aboutsummaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32/ucontext-reentrant.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/libc0.9.32/ucontext-reentrant.patch')
-rw-r--r--main/libc0.9.32/ucontext-reentrant.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/main/libc0.9.32/ucontext-reentrant.patch b/main/libc0.9.32/ucontext-reentrant.patch
new file mode 100644
index 0000000000..2417e15a48
--- /dev/null
+++ b/main/libc0.9.32/ucontext-reentrant.patch
@@ -0,0 +1,12 @@
+diff --git a/libc/sysdeps/linux/i386/Makefile.arch b/libc/sysdeps/linux/i386/Makefile.arch
+index b47f5a0..8b1edc2 100644
+--- a/libc/sysdeps/linux/i386/Makefile.arch
++++ b/libc/sysdeps/linux/i386/Makefile.arch
+@@ -18,4 +18,7 @@ endif
+
+ ifeq ($(UCLIBC_HAS_CONTEXT_FUNCS),y)
+ SSRC += makecontext.S setcontext.S getcontext.S swapcontext.S
++ASFLAGS-setcontext.S := -D_LIBC_REENTRANT
++ASFLAGS-getcontext.S := -D_LIBC_REENTRANT
++ASFLAGS-swapcontext.S := -D_LIBC_REENTRANT
+ endif