aboutsummaryrefslogtreecommitdiffstats
path: root/main/libconfig
diff options
context:
space:
mode:
Diffstat (limited to 'main/libconfig')
-rw-r--r--main/libconfig/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/main/libconfig/APKBUILD b/main/libconfig/APKBUILD
index 3698b8ef06..18c529221f 100644
--- a/main/libconfig/APKBUILD
+++ b/main/libconfig/APKBUILD
@@ -1,21 +1,20 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libconfig
-pkgver=1.5
-pkgrel=3
+pkgver=1.7.2
+pkgrel=0
pkgdesc="A simple library for manipulating structured configuration files"
url="http://www.hyperrealm.com/libconfig/"
arch="all"
-license="LGPL"
-makedepends="autoconf automake libtool"
+license="LGPL-2.1-or-later"
+makedepends="automake autoconf libtool texinfo"
+subpackages="$pkgname-static $pkgname-doc $pkgname-dev $pkgname++:_cxx"
source="$pkgname-$pkgver.tar.gz::https://github.com/hyperrealm/$pkgname/archive/v$pkgver.tar.gz"
-subpackages="$pkgname-doc $pkgname-dev $pkgname++:_cxx"
-
-builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$builddir"
default_prepare
- autoreconf -vif
+ autoreconf -fi
}
build() {
@@ -44,4 +43,11 @@ _cxx() {
mv "$pkgdir"/usr/lib/libconfig++.so.* "$subpkgdir"/usr/lib/
}
-sha512sums="f3a0a969d56604c473b004fd15e541569a6b7639a23db896e391d6280060c278f0adbae1da92bc2a9a55431e74a9312d7581cc47dc27d043a9ac3b045ae2a8a0 libconfig-1.5.tar.gz"
+static() {
+ depends=""
+ pkgdesc="$pkgdesc (static libraries)"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib
+}
+
+sha512sums="9df57355c2d08381b4a0a6366f0db3633fbe8f73c2bb8c370c040b0bae96ce89ee4ac6c17a5a247fed855d890fa383e5b70cb5573fc9cfc62194d5b94e161cee libconfig-1.7.2.tar.gz"