aboutsummaryrefslogtreecommitdiffstats
path: root/main/libcrystalhd/gcc-opts-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/libcrystalhd/gcc-opts-fix.patch')
-rw-r--r--main/libcrystalhd/gcc-opts-fix.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/main/libcrystalhd/gcc-opts-fix.patch b/main/libcrystalhd/gcc-opts-fix.patch
new file mode 100644
index 0000000000..c89c43d7fd
--- /dev/null
+++ b/main/libcrystalhd/gcc-opts-fix.patch
@@ -0,0 +1,17 @@
+Description: Patch to fix build failures on non x86 machines.
+Origin: Debian
+
+--- a/linux_lib/libcrystalhd/Makefile
++++ b/linux_lib/libcrystalhd/Makefile
+@@ -24,7 +24,10 @@
+ # -D_USE_SHMEM_
+
+ CPPFLAGS += ${INCLUDES}
+-CPPFLAGS += -O2 -Wall -fPIC -shared -fstrict-aliasing -msse2
++CPPFLAGS += -O2 -Wall -fPIC -shared -fstrict-aliasing
++MACHINE_OPTS = $(shell gcc -xc -c /dev/null -msse2 -o /dev/null \
++ >/dev/null 2>&1 && echo -msse2)
++CPPFLAGS += $(MACHINE_OPTS)
+ LDFLAGS = -Wl,-soname,${BCLIB_SL} -pthread
+
+ SRCFILES = libcrystalhd_if.cpp \