aboutsummaryrefslogtreecommitdiffstats
path: root/main/libical/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libical/APKBUILD')
-rw-r--r--main/libical/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/main/libical/APKBUILD b/main/libical/APKBUILD
new file mode 100644
index 0000000000..f0cb1c2dfb
--- /dev/null
+++ b/main/libical/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libical
+pkgver=0.46
+pkgrel=2
+pkgdesc="An open source reference implementation of the icalendar data type and serialization format"
+url="http://sourceforge.net/projects/freeassociation/"
+arch="all"
+license="LGPL MPL"
+depends=
+makedepends="perl autoconf automake libtool"
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/freeassociation/$pkgname-$pkgver.tar.gz"
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ aclocal && autoheader && autoconf && automake -a || return 1
+ libtoolize --force
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make -j1 DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="9c08f88945bfd5d0791d102e4aa4125c libical-0.46.tar.gz"