aboutsummaryrefslogtreecommitdiffstats
path: root/main/libinput/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libinput/APKBUILD')
-rw-r--r--main/libinput/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/main/libinput/APKBUILD b/main/libinput/APKBUILD
new file mode 100644
index 0000000000..3c855ca549
--- /dev/null
+++ b/main/libinput/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
+pkgname=libinput
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="Library for handling input devices"
+url="http://www.freedesktop.org/wiki/Software/libinput/"
+arch="all"
+license="custom"
+depends=""
+makedepends="mtdev-dev eudev-dev libevdev-dev grep"
+subpackages="$pkgname-dev $pkgname-doc"
+options="!check"
+source="http://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-libwacom \
+ || return 1
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" -C "$builddir" install
+}
+
+sha512sums="9058eab813ea3de230835155ca843f248127cbafaf1aecc9a2e209a0215b090beef0468cc863a24320f8d0db1f2863baba680e2416e9e409e958b2c1d18e43a1 libinput-1.7.0.tar.xz"