aboutsummaryrefslogtreecommitdiffstats
path: root/main/liblockfile
diff options
context:
space:
mode:
Diffstat (limited to 'main/liblockfile')
-rw-r--r--main/liblockfile/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/main/liblockfile/APKBUILD b/main/liblockfile/APKBUILD
index d5ab481357..c655ea6a98 100644
--- a/main/liblockfile/APKBUILD
+++ b/main/liblockfile/APKBUILD
@@ -1,16 +1,14 @@
# Contributor: Duane Hughes <duanejevon@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=liblockfile
-pkgver=1.14
+pkgver=1.15
pkgrel=0
pkgdesc="Shared library with NFS-safe locking functions"
-url="http://packages.debian.org/sid/liblockfile1"
+url="https://github.com/miquels/liblockfile"
arch="all"
-license="GPL"
-options="!check" # upstream does not provide tests
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://ftp.debian.org/debian/pool/main/libl/liblockfile/${pkgname}_$pkgver.orig.tar.gz"
-builddir="$srcdir/$pkgname"
+license="LGPL-2.0-or-later and GPL-2.0-or-later"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/miquels/$pkgname/archive/v$pkgver.tar.gz"
build() {
cd "$builddir"
@@ -22,9 +20,14 @@ build() {
make -j1
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}
-sha512sums="d6d75a1ddb55bae8ee63bd0cbacf7ab8cd6d28b29a7d3c2e4a5c31c76c6743ed517cdebd42e3ef5c44698faebfd1537b023510c692b54a1275e7114605fe6550 liblockfile_1.14.orig.tar.gz"
+sha512sums="486c7cdcb340bee8aecc92ac667b39758faa865857e14a1c087dadf2a3031edbd6cc67ec8dd8b641e76184e80ba934cbad0dc053e888b66ee54617ad470b7776 liblockfile-1.15.tar.gz"