aboutsummaryrefslogtreecommitdiffstats
path: root/main/libnl3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libnl3/APKBUILD')
-rw-r--r--main/libnl3/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/main/libnl3/APKBUILD b/main/libnl3/APKBUILD
index eb9db896b0..0ddd5e3b73 100644
--- a/main/libnl3/APKBUILD
+++ b/main/libnl3/APKBUILD
@@ -1,12 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libnl3
-pkgver=3.4.0
+pkgver=3.5.0
pkgrel=0
pkgdesc="Library for applications dealing with netlink sockets"
url="http://www.infradead.org/~tgr/libnl/"
arch="all"
-license="GPL"
-depends=
+license="LGPL-2.1-or-later"
makedepends="linux-headers flex bison libtool autoconf automake"
checkdepends="check-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-cli"
@@ -15,13 +14,13 @@ source="https://github.com/thom311/libnl/releases/download/libnl${pkgver//./_}/l
"
builddir="$srcdir"/libnl-$pkgver
-prepare () {
+prepare() {
default_prepare
cd "$builddir"
autoreconf -vif
}
-build () {
+build() {
cd "$builddir"
./configure \
--build=$CBUILD \
@@ -54,5 +53,5 @@ cli() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="6336e5c55c79ff2638de9c812cc1842871769236bad7f65c547dec35fafd91988b257fceab144a0cc133c4b29f61172f6552c53aa9fc723bdc783079c2b1851e libnl-3.4.0.tar.gz
-a31ec4b76d2fc472072f2d770cb3f5819a6477230a97603a476ce175c0c94d25e74eff8dc0ce2e6baa96f0e450b82db508a152f418bdd72919cbd5521d5f82fd libnl3-musl.patch"
+sha512sums="9c94c09bac34297493b3ea482713d7c0865d2839b5042e5c7d1ed008e2402ab63df35a18e272f40b2cce27d0c31dc733fe7e4b2d376e7ca847a2b0d5e90de50c libnl-3.5.0.tar.gz
+2b9b569c00b9e29930a83e88264e9cb63a4991bd89a04f2fc4b4c468a2a73309d9463f0b9e4a945e614c0f831a68fc99c5768a0f2214a0dde00785215e24e1dc libnl3-musl.patch"