aboutsummaryrefslogtreecommitdiffstats
path: root/main/libpthread-stubs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libpthread-stubs/APKBUILD')
-rw-r--r--main/libpthread-stubs/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/main/libpthread-stubs/APKBUILD b/main/libpthread-stubs/APKBUILD
index 30a2d9159c..1c6c100216 100644
--- a/main/libpthread-stubs/APKBUILD
+++ b/main/libpthread-stubs/APKBUILD
@@ -9,8 +9,15 @@ license="X11"
depends=
source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \