aboutsummaryrefslogtreecommitdiffstats
path: root/main/libpthread-stubs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libpthread-stubs/APKBUILD')
-rw-r--r--main/libpthread-stubs/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/main/libpthread-stubs/APKBUILD b/main/libpthread-stubs/APKBUILD
index d322460970..d5106e002a 100644
--- a/main/libpthread-stubs/APKBUILD
+++ b/main/libpthread-stubs/APKBUILD
@@ -1,19 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libpthread-stubs
pkgver=0.3
-pkgrel=3
+pkgrel=4
pkgdesc="Pthread functions stubs for platforms missing them"
url="http://cgit.freedesktop.org/xcb/pthread-stubs"
arch="all"
license="X11"
depends=
+options="!dbg"
source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$_builddir"
- update_config_sub || return 1
+ update_config_sub
}
build() {
@@ -21,11 +22,8 @@ build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
- # we actually have pthread_exit, the configure script just
- # fails to detect it
- make CFLAGS="$CFLAGS -DHAVE_PTHREAD_EXIT=1"
+ --prefix=/usr
+ make
}
package() {