aboutsummaryrefslogtreecommitdiffstats
path: root/main/libressl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libressl/APKBUILD')
-rw-r--r--main/libressl/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/main/libressl/APKBUILD b/main/libressl/APKBUILD
index 0f11b189e1..2aa90f0855 100644
--- a/main/libressl/APKBUILD
+++ b/main/libressl/APKBUILD
@@ -7,26 +7,28 @@
# - CVE-2017-8301
#
pkgname=libressl
-pkgver=2.5.5
+pkgver=2.6.3
_namever=${pkgname}${pkgver%.*}
-pkgrel=4
+pkgrel=0
pkgdesc="Version of the TLS/crypto stack forked from OpenSSL"
url="http://www.libressl.org/"
arch="all"
license="custom"
depends=""
makedepends_build=""
-makedepends_host="linux-headers"
+makedepends_host="linux-headers automake autoconf libtool"
makedepends="$makedepends_host"
replaces="openssl"
subpackages="$pkgname-dbg $_namever-libcrypto:_libs $_namever-libssl:_libs
$_namever-libtls:_libs $pkgname-dev $pkgname-doc"
source="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/$pkgname-$pkgver.tar.gz
starttls-ldap.patch
+ ssl-libcompat.patch
"
builddir="$srcdir/$pkgname-$pkgver"
build() {
+ autoreconf -vif
cd "$builddir"
CFLAGS="-L$CBUILDROOT/usr/lib $CFLAGS" \
./configure \
@@ -72,5 +74,6 @@ _libs() {
fi
}
-sha512sums="3f576e74ddea17bd72e1bfbe0b57b94e1a2a9e6fa56cee50624cd8d18f0a8674273086225669e6ece56e6b859d2376e36e2c140d37acb52d4cd79374c4ba7096 libressl-2.5.5.tar.gz
-07e523ae321b4a6a4afbac7acf4bd30e887b8e18ab2801ca42ba48af130b1cb43d56e70d1039b248c6251623b57c1c638db59105e6fbf4e6175be50d67a0473d starttls-ldap.patch"
+sha512sums="5c0a0f86ecad1226c2d9a3a8a2e6f412ac0941d402c213ae1d293cd90c6a684198410db8c5250f83b8e2b00968a089afc39e90e053669fc27f82a4eb7c65f5c9 libressl-2.6.3.tar.gz
+07e523ae321b4a6a4afbac7acf4bd30e887b8e18ab2801ca42ba48af130b1cb43d56e70d1039b248c6251623b57c1c638db59105e6fbf4e6175be50d67a0473d starttls-ldap.patch
+ef8150843f5aae577a859198439673591764fb3ab1da03436607328962f084356fd7f793484c3ad5f2294bd9e8dad15644c311b0da811acbc83eed4b71c0145a ssl-libcompat.patch"