aboutsummaryrefslogtreecommitdiffstats
path: root/main/libressl
diff options
context:
space:
mode:
Diffstat (limited to 'main/libressl')
-rw-r--r--main/libressl/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/main/libressl/APKBUILD b/main/libressl/APKBUILD
index f24efb5938..321edb0173 100644
--- a/main/libressl/APKBUILD
+++ b/main/libressl/APKBUILD
@@ -27,9 +27,16 @@ source="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/$pkgname-$pkgver.tar.gz
"
builddir="$srcdir/$pkgname-$pkgver"
-build() {
+prepare() {
+ default_prepare
+
+ cd "$builddir"
autoreconf -vif
+}
+
+build() {
cd "$builddir"
+
CFLAGS="-L$CBUILDROOT/usr/lib $CFLAGS" \
./configure \
--build=$CBUILD \