aboutsummaryrefslogtreecommitdiffstats
path: root/main/libtirpc/libtirpc-no-des.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/libtirpc/libtirpc-no-des.patch')
-rw-r--r--main/libtirpc/libtirpc-no-des.patch20
1 files changed, 10 insertions, 10 deletions
diff --git a/main/libtirpc/libtirpc-no-des.patch b/main/libtirpc/libtirpc-no-des.patch
index 8c59de21f8..7ebb6447ce 100644
--- a/main/libtirpc/libtirpc-no-des.patch
+++ b/main/libtirpc/libtirpc-no-des.patch
@@ -1,5 +1,5 @@
---- ./src/Makefile.am.orig
-+++ ./src/Makefile.am
+--- libtirpc-0.2.2.orig/src/Makefile.am
++++ libtirpc-0.2.2/src/Makefile.am
@@ -40,7 +40,7 @@
# release number of your package. This is an abuse that only fosters
# misunderstanding of the purpose of library versions."
@@ -13,14 +13,14 @@
rpc_callmsg.c rpc_generic.c rpc_soc.c rpcb_clnt.c rpcb_prot.c \
rpcb_st_xdr.c svc.c svc_auth.c svc_dg.c svc_auth_unix.c svc_generic.c \
svc_raw.c svc_run.c svc_simple.c svc_vc.c getpeereid.c \
-- auth_time.c auth_des.c authdes_prot.c
-+ auth_time.c
+- auth_time.c auth_des.c authdes_prot.c des_crypt.c
++ auth_time.c
## XDR
libtirpc_la_SOURCES += xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c
---- ./src/rpc_soc.c.orig
-+++ ./src/rpc_soc.c
-@@ -479,6 +479,7 @@
+--- libtirpc-0.2.2.orig/src/rpc_soc.c
++++ libtirpc-0.2.2/src/rpc_soc.c
+@@ -515,6 +515,7 @@
(resultproc_t) rpc_wrap_bcast, "udp");
}
@@ -28,11 +28,11 @@
/*
* Create the client des authentication object. Obsoleted by
* authdes_seccreate().
-@@ -511,6 +512,7 @@
+@@ -546,6 +547,7 @@
+ dummy = authdes_seccreate(servername, window, NULL, ckey);
return (dummy);
}
-
+#endif
+
/*
* Create a client handle for a unix connection. Obsoleted by clnt_vc_create()
- */