aboutsummaryrefslogtreecommitdiffstats
path: root/main/libtorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libtorrent/APKBUILD')
-rw-r--r--main/libtorrent/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/libtorrent/APKBUILD b/main/libtorrent/APKBUILD
index d7d0dad963..b938de68e0 100644
--- a/main/libtorrent/APKBUILD
+++ b/main/libtorrent/APKBUILD
@@ -12,8 +12,15 @@ subpackages="$pkgname-dev"
options='libtool'
source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
@@ -25,7 +32,7 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}