aboutsummaryrefslogtreecommitdiffstats
path: root/main/libvdpau/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libvdpau/APKBUILD')
-rw-r--r--main/libvdpau/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/libvdpau/APKBUILD b/main/libvdpau/APKBUILD
new file mode 100644
index 0000000000..b87fba81fe
--- /dev/null
+++ b/main/libvdpau/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=libvdpau
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="Nvidia VDPAU library"
+url="http://cgit.freedesktop.org/~aplattner/libvdpau"
+arch="all"
+license="custom"
+depends=
+makedepends="libx11-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://people.freedesktop.org/~aplattner/vdpau/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/vdpau/*.la \
+ "$pkgdir"/usr/lib/*.la || return 1
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
+}
+
+md5sums="8e1f0639bea4e4a842aee93ab64406cc libvdpau-0.4.1.tar.gz"