aboutsummaryrefslogtreecommitdiffstats
path: root/main/libvirt
diff options
context:
space:
mode:
Diffstat (limited to 'main/libvirt')
-rw-r--r--main/libvirt/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/main/libvirt/APKBUILD b/main/libvirt/APKBUILD
index 8cdd6a1340..ed81e3e87c 100644
--- a/main/libvirt/APKBUILD
+++ b/main/libvirt/APKBUILD
@@ -2,7 +2,7 @@
pkgname=libvirt
pkgver=1.1.1
_ver="${pkgver/_rc/-rc}"
-pkgrel=0
+pkgrel=1
pkgdesc="A virtualization API for several hypervisor and container systems"
url="http://libvirt.org/"
arch="all"
@@ -28,7 +28,7 @@ source="http://libvirt.org/sources/$pkgname-$pkgver.tar.gz
uclibc-physmem.patch
"
-if [ "$ALPINE_LIBC" != "eglibc" ]; then
+if [ "$CARCH" = "x86_64" ]; then
subpackages="$subpackages $pkgname-xen"
makedepends="$makedepends xen-dev"
fi
@@ -59,6 +59,10 @@ prepare() {
build() {
cd "$_builddir"
export LDFLAGS="$LDFLAGS -lm"
+ local _xen_opt=
+ if [ "$CARCH" = x86_64 ]; then
+ _xen_opt="--with-libxl"
+ fi
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -67,7 +71,7 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--libexec=/usr/lib/"$pkgname" \
- --with-libxl \
+ $_xen_opt \
--with-polkit \
|| return 1
make || return 1