aboutsummaryrefslogtreecommitdiffstats
path: root/main/libvpx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libvpx/APKBUILD')
-rw-r--r--main/libvpx/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/main/libvpx/APKBUILD b/main/libvpx/APKBUILD
new file mode 100644
index 0000000000..b69f364339
--- /dev/null
+++ b/main/libvpx/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libvpx
+pkgver=0.9.1
+pkgrel=0
+pkgdesc="Library for the vp8 codec"
+url="http://www.webmproject.org/"
+license="GPL"
+depends=
+makedepends="coreutils yasm bash perl"
+install=
+subpackages="$pkgname-dev"
+source="http://webm.googlecode.com/files/libvpx-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --enable-pic \
+ --enable-libs \
+ --enable-runtime-cpu-detect \
+ --enable-vp8 \
+ --disable-install-srcs \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DIST_DIR="$pkgdir"/usr install
+}
+
+md5sums="e1442e74d0cca228785083fa520735a2 libvpx-0.9.1.tar.bz2"