aboutsummaryrefslogtreecommitdiffstats
path: root/main/libwebp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libwebp/APKBUILD')
-rw-r--r--main/libwebp/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/main/libwebp/APKBUILD b/main/libwebp/APKBUILD
index d9e5505089..52db03b2ec 100644
--- a/main/libwebp/APKBUILD
+++ b/main/libwebp/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libwebp
pkgver=0.6.0
-pkgrel=0
+pkgrel=1
pkgdesc="Libraries for working with WebP images"
url="https://developers.google.com/speed/webp/"
arch="all"
@@ -23,14 +23,18 @@ build() {
--disable-static \
--enable-libwebpmux \
--enable-libwebpdemux \
- --enable-libwebpdecoder \
- || return 1
- make || return 1
+ --enable-libwebpdecoder
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/share/doc/$pkgname
install -Dm644 PATENTS README "$pkgdir"/usr/share/doc/$pkgname
}