aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxcomposite/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libxcomposite/APKBUILD')
-rw-r--r--main/libxcomposite/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/libxcomposite/APKBUILD b/main/libxcomposite/APKBUILD
new file mode 100644
index 0000000000..461450ee6b
--- /dev/null
+++ b/main/libxcomposite/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxcomposite
+pkgver=0.4.3
+pkgrel=2
+pkgdesc="X11 Composite extension library"
+url="http://xorg.freedesktop.org/"
+arch="all"
+license="custom"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="pkgconfig libxfixes-dev libxext-dev compositeproto"
+source="http://xorg.freedesktop.org//releases/individual/lib/libXcomposite-$pkgver.tar.bz2"
+
+depends_dev="xproto compositeproto libxfixes-dev libx11-dev libxext-dev"
+_builddir="$srcdir"/libXcomposite-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+ install -D -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="a60e0b5c276d0aa9e2d3b982c98f61c8 libXcomposite-0.4.3.tar.bz2"