aboutsummaryrefslogtreecommitdiffstats
path: root/main/lighttpd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lighttpd/APKBUILD')
-rw-r--r--main/lighttpd/APKBUILD118
1 files changed, 118 insertions, 0 deletions
diff --git a/main/lighttpd/APKBUILD b/main/lighttpd/APKBUILD
new file mode 100644
index 0000000000..7154931f3c
--- /dev/null
+++ b/main/lighttpd/APKBUILD
@@ -0,0 +1,118 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lighttpd
+pkgver=1.4.29
+_streamver=2.2.0
+pkgrel=0
+pkgdesc="a secure, fast, compliant and very flexible web-server"
+url="http://www.lighttpd.net/"
+arch="all"
+license="custom"
+install="$pkgname.pre-install $pkgname.post-install"
+depends=
+makedepends="flex pcre-dev openssl-dev zlib-dev bzip2-dev lua-dev pkgconfig
+ automake autoconf openldap-dev"
+source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.tar.bz2
+ http://h264.code-shop.com/download/lighttpd-1.4.18_mod_h264_streaming-$_streamver.tar.gz
+ $pkgname.initd
+ $pkgname.confd
+ $pkgname.logrotate
+ spawn-fcgi.confd
+ spawn-fcgi.initd
+ lighttpd.conf
+ mime-types.conf
+ mod_cgi.conf
+ mod_fastcgi.conf
+ mod_fastcgi_fpm.conf
+ "
+subpackages="$pkgname-doc $pkgname-h264_streaming"
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ # copy over the mod-h264-streaming mod
+ # http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Lighttpd-Version2#DownloadLighttpd1.4.191.4.20andother1.4.x
+ cp "$srcdir"/lighttpd-1.4.18/src/moov.* src/
+ cp "$srcdir"/lighttpd-1.4.18/src/mod_h264_streaming.c src/
+
+ cat >> src/Makefile.am <<__EOF__
+
+lib_LTLIBRARIES += mod_h264_streaming.la
+mod_h264_streaming_la_SOURCES = mod_h264_streaming.c moov.c
+mod_h264_streaming_la_LDFLAGS = -module -export-dynamic -avoid-version -no-undefined
+mod_h264_streaming_la_LIBADD = \$(common_libadd)
+__EOF__
+ aclocal -I m4 && autoconf && automake
+}
+
+build() {
+ local i
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --enable-lfs \
+ --libdir=/usr/lib/lighttpd \
+ --without-mysql \
+ --without-attr \
+ --without-kerberos5 \
+ --without-fam \
+ --without-webdav-props \
+ --without-webdav-locks \
+ --without-gdbm \
+ --without-memcache \
+ --with-bzip2 \
+ --with-ldap \
+ --with-openssl \
+ --with-lua || return 1
+
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/lighttpd/*.la || return 1
+
+ # create dirs
+ install -d -m755 "$pkgdir"/var/run/lighttpd/ \
+ "$pkgdir"/var/log/lighttpd/ \
+ "$pkgdir"/etc/lighttpd/ \
+ "$pkgdir"/var/www/localhost/htdocs
+
+ # lighttpd
+ install -D -m755 "$srcdir"/lighttpd.initd "$pkgdir"/etc/init.d/lighttpd
+ install -D -m644 "$srcdir"/lighttpd.confd "$pkgdir"/etc/conf.d/lighttpd
+ install -D -m644 "$srcdir"/lighttpd.logrotate \
+ "$pkgdir"/etc/logrotate.d/lighttpd
+
+ # spawn-fcgi
+ install -D -m755 "$srcdir"/spawn-fcgi.initd \
+ "$pkgdir"/etc/init.d/spawn-fcgi
+ install -D -m644 "$srcdir"/spawn-fcgi.confd \
+ "$pkgdir"/etc/conf.d/spawn-fcgi
+
+ # config files
+ for i in lighttpd.conf mime-types.conf mod_cgi.conf mod_fastcgi.conf mod_fastcgi_fpm.conf; do
+ install -m644 "$srcdir"/$i "$pkgdir"/etc/lighttpd/$i
+ done
+}
+
+h264_streaming() {
+ pkgdesc="H264 Streaming Module for lighttpd"
+ url="http://h264.code-shop.com/trac"
+ license="CCPL-nc-sa-3.0"
+ mkdir -p "$subpkgdir"/usr/lib/lighttpd
+ mv "$pkgdir"/usr/lib/lighttpd/mod_h264_streaming.so \
+ "$subpkgdir"/usr/lib/lighttpd/
+}
+
+md5sums="e6e67b09986cb504db630b5a86b2dd76 lighttpd-1.4.29.tar.bz2
+ac37885c881a058194405232e7737a7a lighttpd-1.4.18_mod_h264_streaming-2.2.0.tar.gz
+e37770e4eed20390806a2420a3970fcd lighttpd.initd
+0dede109282bfe685bdec6b35f0e4b6b lighttpd.confd
+ad091c9157134890499f26d170352c9f lighttpd.logrotate
+1d925aed297ec4541fb230dd19e11bc1 spawn-fcgi.confd
+2f177ba0a35fd1c683edef3453c20bc8 spawn-fcgi.initd
+268bf5dd2c370ee5e119246775ac5640 lighttpd.conf
+fef397e7bcf1b741dea211a555e1803c mime-types.conf
+9c1407e95f62ed22da66c4ef5f69c3b5 mod_cgi.conf
+f3363e39832f1b6678468b482d121afb mod_fastcgi.conf
+aee5947a1abf380b0685a534ca384b42 mod_fastcgi_fpm.conf"