aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-grsec/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/linux-grsec/APKBUILD')
-rw-r--r--main/linux-grsec/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 25c0103dbb..0cde93349f 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -2,9 +2,9 @@
_flavor=grsec
pkgname=linux-${_flavor}
-pkgver=2.6.30.5
+pkgver=2.6.30.6
_kernver=2.6.30
-pkgrel=3
+pkgrel=0
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs"
@@ -13,7 +13,7 @@ _config=${config:-kernelconfig}
install="$pkgname.post-install $pkgname.post-upgrade"
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
- grsecurity-2.1.14-2.6.30.5-200909052209.patch
+ grsecurity-2.1.14-2.6.30.6-200909091844.patch
net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
$_config
"
@@ -62,6 +62,8 @@ build() {
rm -f "$pkgdir"/lib/modules/${_abi_release}/build \
"$pkgdir"/lib/modules/${_abi_release}/source
+ install -D include/config/kernel.release \
+ "$pkgdir"/usr/share/$pkgname/kernel.release
}
dev() {
@@ -111,7 +113,7 @@ dev() {
}
md5sums="7a80058a6382e5108cdb5554d1609615 linux-2.6.30.tar.bz2
-47841c7ff5c81a7b349a79f2fa8e9138 patch-2.6.30.5.bz2
-82ed9db7fcd03659aeb2d597982182b7 grsecurity-2.1.14-2.6.30.5-200909052209.patch
+f89295707f68c2b349534b490c9d5f2d patch-2.6.30.6.bz2
+15313bb5bc54aacb96508b5e19e94bc7 grsecurity-2.1.14-2.6.30.6-200909091844.patch
ca05fd252783b82e01610e775cf56498 net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
35d29ea012d4b009ce2bd37b7540903e kernelconfig"