aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-vserver/fixes-for-using-make-3.82.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/linux-vserver/fixes-for-using-make-3.82.patch')
-rw-r--r--main/linux-vserver/fixes-for-using-make-3.82.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/main/linux-vserver/fixes-for-using-make-3.82.patch b/main/linux-vserver/fixes-for-using-make-3.82.patch
new file mode 100644
index 0000000000..dd6e6ace97
--- /dev/null
+++ b/main/linux-vserver/fixes-for-using-make-3.82.patch
@@ -0,0 +1,25 @@
+--- linux-2.6.36-rc1/firmware/Makefile
++++ 2.6.36-rc1-make-3.82-fixes/firmware/Makefile
+@@ -142,7 +142,7 @@ fw-shipped-$(CONFIG_YAM) += yam/1200.bin
+ fw-shipped-all := $(fw-shipped-y) $(fw-shipped-m) $(fw-shipped-)
+
+ # Directories which we _might_ need to create, so we have a rule for them.
+-firmware-dirs := $(sort $(patsubst %,$(objtree)/$(obj)/%/,$(dir $(fw-external-y) $(fw-shipped-all))))
++firmware-dirs := $(sort $(addprefix $(objtree)/$(obj)/,$(dir $(fw-external-y) $(fw-shipped-all))))
+
+ quiet_cmd_mkdir = MKDIR $(patsubst $(objtree)/%,%,$@)
+ cmd_mkdir = mkdir -p $@
+--- linux-2.6.36-rc1/scripts/mkmakefile
++++ 2.6.36-rc1-make-3.82-fixes/scripts/mkmakefile
+@@ -44,7 +44,9 @@ all:
+
+ Makefile:;
+
+-\$(all) %/: all
++\$(all): all
+ @:
+
++%/: all
++ @:
+ EOF
+