aboutsummaryrefslogtreecommitdiffstats
path: root/main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch')
-rw-r--r--main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch b/main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch
new file mode 100644
index 0000000000..89174112b6
--- /dev/null
+++ b/main/llvm/clang-0009-pass-host-triple-to-compiler-rt.patch
@@ -0,0 +1,12 @@
+diff --git i/runtime/CMakeLists.txt w/runtime/CMakeLists.txt
+index 9f1cd78..5b3da2e 100644
+--- i/runtime/CMakeLists.txt
++++ w/runtime/CMakeLists.txt
+@@ -46,6 +46,7 @@ if(LLVM_BUILD_EXTERNAL_COMPILER_RT AND EXISTS ${COMPILER_RT_SRC_ROOT}/)
+ -DCOMPILER_RT_INSTALL_PATH=lib${LLVM_LIBDIR_SUFFIX}/clang/${CLANG_VERSION}
+ -DCOMPILER_RT_INCLUDE_TESTS=${LLVM_INCLUDE_TESTS}
+ -DCOMPILER_RT_ENABLE_WERROR=ON
++ -DLLVM_HOST_TRIPLE=${LLVM_HOST_TRIPLE}
+ INSTALL_COMMAND ""
+ STEP_TARGETS configure build
+ )