aboutsummaryrefslogtreecommitdiffstats
path: root/main/llvm5
diff options
context:
space:
mode:
Diffstat (limited to 'main/llvm5')
-rw-r--r--main/llvm5/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/main/llvm5/APKBUILD b/main/llvm5/APKBUILD
index 261319c48d..24bf82a342 100644
--- a/main/llvm5/APKBUILD
+++ b/main/llvm5/APKBUILD
@@ -6,7 +6,7 @@ _pkgname=llvm
pkgver=5.0.1
_majorver=${pkgver%%.*}
pkgname=$_pkgname$_majorver
-pkgrel=3
+pkgrel=4
pkgdesc="Low Level Virtual Machine compiler system, version $_majorver"
arch="all"
url="http://llvm.org/"
@@ -124,12 +124,7 @@ build() {
check() {
cd "$builddir"/build
- # XXX: Few tests fail on s390x, ignore it for now. See build log
- # https://gist.github.com/jirutka/6edc951ad5b8002cf1780546cf661edc
- case "$CARCH" in
- s390x) make check-llvm || true;;
- *) make check-llvm;;
- esac
+ make check-llvm
}
package() {