aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-feedparser
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-feedparser')
-rw-r--r--main/lua-feedparser/APKBUILD16
1 files changed, 16 insertions, 0 deletions
diff --git a/main/lua-feedparser/APKBUILD b/main/lua-feedparser/APKBUILD
index 1f768f2e32..270f49169e 100644
--- a/main/lua-feedparser/APKBUILD
+++ b/main/lua-feedparser/APKBUILD
@@ -13,11 +13,27 @@ replaces="$pkgname-common" # for backward compatibility
source="$pkgname-$pkgver.tar.gz::https://github.com/slact/$pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
+# luajit is not available for selected arches
+case "$CARCH" in
+ s390x) _luajit="";;
+ *) checkdepends="$checkdepends luajit" _luajit="jit";;
+esac
+
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
+ checkdepends="$checkdepends lua$_v"
provides="$provides lua$_v-${pkgname#lua-}=$pkgver-r$pkgrel" # for backward compatibility
done
+check() {
+ cd "$builddir"
+
+ local lver; for lver in $_luaversions $_luajit; do
+ msg "Testing on Lua $lver"
+ make test LUA_BIN=lua$lver
+ done
+}
+
package() {
local lmod_dir="$pkgdir/usr/share/lua/common"
local rockdir="$pkgdir/usr/lib/luarocks/rocks-common/$_rockname/$pkgver-3"