aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-hashids/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-hashids/APKBUILD')
-rw-r--r--main/lua-hashids/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/main/lua-hashids/APKBUILD b/main/lua-hashids/APKBUILD
new file mode 100644
index 0000000000..91ca0c74e2
--- /dev/null
+++ b/main/lua-hashids/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=lua-hashids
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="A Lua implementation of hashids"
+url="https://github.com/leihog/hashids.lua"
+arch="all"
+license="MIT"
+depends=""
+depends_dev="lua5.1-dev"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="hashids.lua-$pkgver.tar.gz::https://github.com/leihog/hashids.lua/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/hashids.lua-$pkgver
+
+prepare() {
+ local i
+ cd "$_sdir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm644 hashids/init.lua \
+ "$pkgdir"/usr/share/lua/5.1/hashids/init.lua || return 1
+ install -Dm755 hashids/clib.so \
+ "$pkgdir"/usr/lib/lua/5.1/hashids/clib.so || return 1
+}
+
+md5sums="ace60336593b06eb7f7e8a9e37b5a0fd hashids.lua-1.0.0.tar.gz"
+sha256sums="2a99927bba9c986be544d6c483b953c8f39b56cd5915a154553154c8aab7e3fc hashids.lua-1.0.0.tar.gz"
+sha512sums="2d9f6928c82f0ce3e70f729f8f366f85bd2482474e841524c894381a125a27d5e209bf2f9a7b9e5d9fd476fd3865aca2be4c9c2118ebe125995fbd3008a1962a hashids.lua-1.0.0.tar.gz"