aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-resty-lrucache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-resty-lrucache/APKBUILD')
-rw-r--r--main/lua-resty-lrucache/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/lua-resty-lrucache/APKBUILD b/main/lua-resty-lrucache/APKBUILD
new file mode 100644
index 0000000000..01e349ab4e
--- /dev/null
+++ b/main/lua-resty-lrucache/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Michael Pirogov <vbnet.ru@gmail.com>
+# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
+pkgname=lua-resty-lrucache
+pkgver=0.09
+pkgrel=1
+pkgdesc="Lua-land LRU Cache based on LuaJIT FFI"
+url="https://github.com/openresty/lua-resty-lrucache"
+arch="noarch"
+license="BSD-2-Clause"
+depends="luajit"
+source="https://github.com/openresty/lua-resty-lrucache/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+options="!check" # FIXME: tests require OpenResty and additional dependencies
+
+package() {
+ make install DESTDIR="$pkgdir" LUA_LIB_DIR="/usr/share/lua/common"
+
+ echo 'rock_manifest = {}' > rock_manifest
+ install -D -m 644 rock_manifest \
+ "$pkgdir"/usr/lib/luarocks/rocks-common/$pkgname/$pkgver-1
+}
+
+sha512sums="0042f5459a5d994ad3837ceeba7884efe85d2ab7194c8b08d026418c7c81c948ae1de91628d29afde45dae44f326fc5fb295988f24e95e5398a52014af50e3e2 lua-resty-lrucache-0.09.tar.gz"