aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-yaml
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-yaml')
-rw-r--r--main/lua-yaml/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/main/lua-yaml/APKBUILD b/main/lua-yaml/APKBUILD
new file mode 100644
index 0000000000..70aaa542a0
--- /dev/null
+++ b/main/lua-yaml/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-yaml
+pkgver=0.2
+pkgrel=0
+pkgdesc="LibYaml binding for Lua"
+url="http://yaml.luaforge.net"
+arch="all"
+license="MIT"
+depends=""
+makedepends="yaml-dev"
+install=""
+subpackages=""
+source="http://luaforge.net/frs/download.php/4284/yaml-$pkgver.tar.gz"
+
+_builddir="$srcdir"/yaml-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/usr/lib/lua/5.1
+ make PREFIX="$pkgdir"/usr install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="18c25a2a6609b2862e3485952cf73634 yaml-0.2.tar.gz"