aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua5.1/lua/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua5.1/lua/APKBUILD')
-rw-r--r--main/lua5.1/lua/APKBUILD66
1 files changed, 0 insertions, 66 deletions
diff --git a/main/lua5.1/lua/APKBUILD b/main/lua5.1/lua/APKBUILD
deleted file mode 100644
index 032a25d932..0000000000
--- a/main/lua5.1/lua/APKBUILD
+++ /dev/null
@@ -1,66 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=lua
-pkgver=5.1.5
-_ver=$pkgver
-pkgrel=1
-pkgdesc="A powerful light-weight programming language designed for extending applications."
-url="http://www.lua.org/"
-arch="all"
-license="MIT"
-depends=
-makedepends="libtool"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="http://www.$pkgname.org/ftp/$pkgname-$_ver.tar.gz
- lua-5.1-make.patch
- lua-5.1-module_paths.patch
- lua-5.1-readline.patch
- "
-
-_builddir="$srcdir"/lua-$_ver
-build ()
-{
- cd "$_builddir"
- for i in $source; do
- case $i in
- patch*|*.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- ;;
- esac
- done
-
- # correct lua versioning
- sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:4:1/' src/Makefile
-
- # we want packages to find our things
- sed -i -e 's:/usr/local:/usr:' etc/lua.pc
-
- cd src
- make CFLAGS=" -DLUA_USE_LINUX $CFLAGS" \
- RPATH="/usr/lib" \
- LIB_LIBS="-lpthread -lm -ldl" \
- V=$pkgver \
- gentoo_all || return 1
-}
-
-package() {
- cd "$_builddir"
- make INSTALL_TOP="$pkgdir"/usr INSTALL_LIB="$pkgdir"/usr/lib \
- V=$pkgver gentoo_install || return 1
-
- install -D -m 644 etc/lua.pc "$pkgdir"/usr/lib/pkgconfig/lua.pc
- install -D -m 644 doc/lua.1 "$pkgdir"/usr/share/man/man1/lua.1
- install -D -m 644 doc/luac.1 "$pkgdir"/usr/share/man/man1/luac.1
-}
-
-libs() {
- pkgdesc="Lua dynamic library runtime"
- replaces="lua"
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/lib "$subpkgdir"/usr/
-}
-
-md5sums="2e115fe26e435e33b0d5c022e4490567 lua-5.1.5.tar.gz
-0145ff6036eb6bfdab427dc8f0c3f3c0 lua-5.1-make.patch
-e60ef15deefb72a5930c498f1184aced lua-5.1-module_paths.patch
-f2205b897edb31292a1f597a7fd638cb lua-5.1-readline.patch"