aboutsummaryrefslogtreecommitdiffstats
path: root/main/make/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/make/APKBUILD')
-rw-r--r--main/make/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/main/make/APKBUILD b/main/make/APKBUILD
new file mode 100644
index 0000000000..57cdf613d7
--- /dev/null
+++ b/main/make/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=make
+pkgver=3.82
+pkgrel=1
+pkgdesc="GNU make utility to maintain groups of programs"
+url="http://www.gnu.org/software/make"
+arch="all"
+license=GPL
+depends=
+subpackages="$pkgname-doc"
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-nls
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="7f7c000e3b30c6840f2e9cf86b254fac make-3.82.tar.gz"