aboutsummaryrefslogtreecommitdiffstats
path: root/main/mdadm/no-werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/mdadm/no-werror.patch')
-rw-r--r--main/mdadm/no-werror.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/main/mdadm/no-werror.patch b/main/mdadm/no-werror.patch
new file mode 100644
index 0000000000..f4164c5950
--- /dev/null
+++ b/main/mdadm/no-werror.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 5fd7f16..5095a42 100644
+--- a/Makefile
++++ b/Makefile
+@@ -43,7 +43,7 @@ KLIBC_GCC = gcc -nostdinc -iwithprefix include -I$(KLIBC)/klibc/include -I$(KLIB
+
+ CC ?= $(CROSS_COMPILE)gcc
+ CXFLAGS ?= -ggdb
+-CWFLAGS = -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
++CWFLAGS = -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter
+ ifdef WARN_UNUSED
+ CWFLAGS += -Wp,-D_FORTIFY_SOURCE=2 -O3
+ endif