aboutsummaryrefslogtreecommitdiffstats
path: root/main/mdocml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/mdocml/APKBUILD')
-rw-r--r--main/mdocml/APKBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/main/mdocml/APKBUILD b/main/mdocml/APKBUILD
index 518e06d457..3e611574f9 100644
--- a/main/mdocml/APKBUILD
+++ b/main/mdocml/APKBUILD
@@ -2,7 +2,7 @@
pkgname=mdocml
_pkgname=mandoc
pkgver=1.14.3
-pkgrel=0
+pkgrel=1
pkgdesc="mdoc/man compiler"
url="http://mdocml.bsd.lv/"
arch="all"
@@ -31,12 +31,13 @@ LIBDIR=/usr/lib
CFLAGS="$CFLAGS"
UTF8_LOCALE="en_US.UTF-8"
MANPATH_DEFAULT="/usr/share/man:/usr/local/man"
+LN="ln -sf"
EOF
}
build() {
cd "$builddir"
- ./configure
+ MANPATH_BASE="/usr/share/man" ./configure
make
}
@@ -48,11 +49,6 @@ check() {
package() {
cd "$builddir"
make -j1 DESTDIR="$pkgdir" base-install lib-install
- for X in usr/bin/apropos usr/bin/whatis usr/bin/man usr/sbin/makewhatis
- do
- rm -f "$pkgdir/$X"
- ln -s /usr/bin/mandoc "$pkgdir/$X"
- done
}
man() {